[qmp-users] Port Forwarding

Gabriel Lucas gabitogol at gmail.com
Thu May 5 19:56:41 CEST 2016


Many thanks Kepler :)

I have been 2 days trying to make it work,

Using xinet.d looks to me a bit of a hack because if there is LUCI to
configure QMP nodes and there is an option for configuring port forwarding,
why should be necesary to install new services or start modifying files
that later could make things dificult to manage.
Nevertheless I will try xinet.d and post back.

I would like to understand how firewall works in QMP meshs. Is there a
tutorial that explains how to set up a port forwarding (to host a website
for example) into a QMP mesh?.

Juanjo is having the same problem at Cepeda. http://cepeda.qui.guifi.net/
Can someone give us a hand?

saludos



On Mon, May 2, 2016 at 10:22 PM, Kleper <kleper at kleper.net> wrote:

> Hi,
>
>
> 2016-05-02 15:16 GMT-05:00 Gabriel Lucas <gabitogol at gmail.com>:
>
>> Hi,
>>
>> I´m trying to learn how to open ports in the next setup.
>>
>>         ISP-Soho-router ---- QMP-Device1 ---- QMP-Device2 ---- server
>>
>>
>>
> I had the same problem. For some reason you can not use iptables rules,
> nor did many tests. I solved using xinet.d to do this kind of port
> forwarding.
>
> https://azouhr.wordpress.com/2012/06/21/port-forwarding-with-xinetd/
>
> with opkg you can install xinet.d
>
> I hope to help you. :)
>
> I can set a DNAT in the ISP router to make port 9001 redirect to port
>> 9001 in QMP-device-1. So when I access from the Internet the public
>> ip:9001 it redirects
>> correctly.
>>
>> IP Scheme
>>
>> ISP-Soho-Router 192.168.1.1
>> QMP-Device1     10.32.64.38/27 - 192.168.1.35 (wan)
>> QMP-Device2     10.32.64.39/27
>> Server          10.32.64.72/27
>>
>> The problem is in the QMP-Device1.
>>
>> I´m trying to do the same to get to the server.
>> I go to Administration-> Network-> Firewall -> Port Forwarding and
>> create a rule like this.
>>
>> Name: web
>> Match: IPv4-TCP, From any host in wan, Via any router IP at port 9001
>> Forward to: IP 10.32.64.72 , port 80 in any zone
>> save and apply
>>
>> I try to connect from Internet to the public IP port 9001 but doesn´t
>> work.
>>
>> Do you any idea of what I am doing wrong?
>>
>> thansk!
>>
>>
>> _______________________________________________
>> qmp-users mailing list
>> qmp-users at mail.qmp.cat
>> https://mail.dabax.net/cgi-bin/mailman/listinfo/qmp-users
>>
>
>
> _______________________________________________
> qmp-users mailing list
> qmp-users at mail.qmp.cat
> https://mail.dabax.net/cgi-bin/mailman/listinfo/qmp-users
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.dabax.net/pipermail/qmp-users/attachments/20160505/960c1c50/attachment.html>


More information about the qmp-users mailing list